summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authornil <nil@tfwhyno.gf>2024-10-02 17:48:56 +0200
committernil <nil@tfwhyno.gf>2024-10-02 17:48:56 +0200
commit0972fa6eab8c9111311f082ba8abfdc6b4a40945 (patch)
tree4eedbdc1a7cfdeee9d651c9871a9f26ab6da56d4 /Cargo.toml
parent012c2c03b29a987ca4eead023ded22e01aa7477b (diff)
commit changes
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..b4a8000
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "ver1"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+actix-web = { version = "4.9.0"}
+sqlx = { version = "0.8.2", features = ["mysql", "macros", "runtime-tokio"] }
+serde = { version = "1.0.210", features = ["derive"] }
+tokio = "1.40.0"
+
+[package.metadata.scripts]
+db_create = "bash ./scripts/create_db.sh"
+db_populate = "bash ./scripts/populate.sh"
+# db_start = "sudo docker start sqlx"
+# db_start = "sudo docker stop sqlx"
+# db_remove = "sudo docker rm sqlx"